多区域ospf、虚连接、末节、完全末节及路由规纳

实验要求:

1.如实验拓扑图

2.R1与R2间属于ospf的区域0,R2与R3属于ospf区域1,R3与R4属于ospf的区域2,R2与R5间采用rip协议;

2.采用虚连接,实现area2与area0通过area1正常连接;

3.设置末节路由、完全末节路由来实现路由表减化;

4.实现全网互通。

1,R1的配置

interface Ethernet0

ip address 192.168.5.1 255.255.255.0

ospf enable area 0.0.0.3

interface Serial0

clock DTECLK1

ip address 192.168.1.1 255.255.255.0

ospf enable area 0.0.0.0

2.R2上的配置

interface Ethernet0

ip address 192.168.6.1 255.255.255.0

interface Serial0

ip address 192.168.1.2 255.255.255.0

ospf enable area 0.0.0.0

interface Serial1

ip address 192.168.2.1 255.255.255.0

ospf enable area 0.0.0.1

rip

network 192.168.6.0

import-route static cost 1

import-route ospf cost 1  // 路由导入ospf协议

ospf enable

import-route static

import-route rip   //ospf 导入rip协议。

注意:在配置好路由以后R4是学习不到area1 和area0上的路由的。

这就需要在R2和R3上配置虚连接。

[r2-ospf]vlink peer-id 192.168.3.1 transit-area 1

vlink peer-id 192.168.3.1 transit-area 0.0.0.1

时间: 2016-02-07

多区域ospf、虚连接、末节、完全末节及路由规纳的相关文章

OSPF的链路状态数据库的路由链路状态信息

上一篇:OSPF接口信息及中继列表OSPF的链路状态数据库的路由链路状态信息更加详细的描述R1路由器的链路状态数据库中每一个学习到的路由信息的具体状态信息.R1#shipospfdatabaserouter查询OSPF的链路状态数据库的路由链路状态信息 OSPFRouterwithID(1.1.1.1)(ProcessID100) 路由ID是1.1.1.1,进程ID是100 RouterLinkStates(Area0) LSage:1320链路状态的老化是1320 Options:(NoTOS

网络中如何配置多区域OSPF路由协议

在众多的路由协议中,ospf有好多优点,比如它适应各种规模的网络(最多支持几千台路由器).无自环.支持区域划分.可以路由分级等.下面我们重点来讲它的区域划分,在这之前我们先来了解一些有关区域划分的基本知识: 1.我们的网络可以看成是由多个自治系统组成,通过搜集和传递自治系统链路状态来动态地发现和传播路由以达到自治系统的信息同步. 2.每个自治系统又可划分为不同的区域,如果一个路由器端口被分配到多个区域内,这个路由器就被称为区域边界路由器ABR,它是指那些处于区域边缘连接多个区域的路由器. 3.通

多区域OSPF实验之详解LSA

一.拓扑图 二.实验目的 1.观察各类LSA的内容通告ID以及链路ID分别是什么 2.各类LSA由谁发出的,作用是什么 3.抓包查看hello包的内容 三.实验步骤 启动R3-R8,配置IP地址并按区域运行ospf 110 1.抓包看hello包的内容 通过抓包看到Hello包的内容包括:Ospf的版本号v2,发送Hello包的路由器的Route-ID,区域ID,认证类型,子网掩码,Hello/dead时间,接口优先级,DR/BDR的接口地址,邻居的RID,应该还有Stub是否存在,因为没有配置

OSPF区域间路由技术

本次介绍OSPF区域间路由技术,内容包括区域间路由原理,使用Network-Summary-LSA描述区域间路由信息,虚连接技术,区域间路由汇聚等内容. 学习目标: 1. 理解区域间路由原理 2. 理解Network-Summary-LSA 3. 理解虚连接 4. 理解区域间路由汇聚 区域边界路由器(ABR)上有多个LSDB,ABR为每个区域维护一个LSDB.ABR将所连接的非骨干区域内的链路状态信息抽象成路由信息,并发布到骨干区域中,由骨干区域进一步发布到其它骨干区域中. ABR也要将骨干区域

OSPF特殊区域总结

一.拓扑图 二.实验目的 观察stub区域以及NSSA区域的路由以及默认路由是如何产生的 说明:不启动R1和R2,启动其他路由器 三.实验步骤 STUB: 1.将AREA1 配置成STUB区域,看STUB区域的配置以及LSA和默认路由的生成 在 R7上配置将RIP重分发到OSPF110, router ospf 110 redistribute rip subnets 在R5上看路由表,结果显示有区域间的路由以及外部路由.区域间由用O IA 标识,外部路由用O E2标识 R5#show ip r

OSPF路由协议在企业网络中的应用

现在的企业网络搭建中经常会用到OSPF,在此对该协议做一些阐述. ospf 称为开放最短路径优先协议,所有设备厂商都支持的一种协议属于链路状态路由协议,适用于大型园区企业网络当中. OSPF具有很多优点,1.采用触发更新路由,只要网络拓扑结构一旦发生变化,立即会触发更新路由表.2.根据链路状态来发送一些路由.3.采用组播发送路由协议.共有两个可用的组播ip地址224.0.0.5.224.0.0.6.5.适用的网络规模很大,几乎没有规模的限制6.metric cost.7.收敛速度比较快,而且不会

《OSPF网络设计解决方案(第2版)》一2.4 OSPF路由分层

2.4 OSPF路由分层 OSPF网络设计解决方案(第2版) OSPF协议最为重要的特性之一便是它支持分层的路由结构.当你思考OSPF如何在这种分层结构上运行时,请牢记下面的两个特点. 为了使得OSPF能够正常地运行,必须存在或创建分层结构. 应当优先关注如何划分明确的拓扑,而不是地址编址. 自治系统(AS)是指在同一管理域内的一组共享相同路由策略的区域的集合.自治系统使用唯一的编号进行标识,该编号可以是公共的或私有的,这取决于网络的需求.自治系统号必须由特定的组织或机构来分配,如北美的Inte

ospf剩余笔记

OSPF 流程图: 带宽 开销 10     100 100    19 1000   4 10000 2 区域的划分减少lsdb的大小 有利于网络管理员故障排除 网络故障不会影响到其他区域 邻接关系建立经历7种状态 down状态:还没有启用ospf时 init初始化状态:启用了ospf:hello交换 two way状态:交换dbd(类似目录:我能到达那些网络)竞选DR BDR exstart状态:???主从?? 交换状态:交换全面的dbd?? loading加载状态:发查询消息?? full

《CCNP ROUTE 300-101认证考试指南》——8.4节选择最优OSPF路由

8.4 选择最优OSPF路由 CCNP ROUTE 300-101认证考试指南 定义LSA类型.创建区域.完整泛洪LSA,所有这些工作都只有一个目的:让区域中的路由器计算出所有已知子网的最优无环路由.虽然数据库的交换过程看起来可能挺费事的,但读者对SPF计算最优路由的过程无需关注太多,至少对于CCNP ROUTE考试的水平来说没有必要.事实上,选择某个特定子网的最优路由,以及特定路由器计算的过程可总结如下: 关键 分析LSDB,以找到去往子网的所有可能的路由: 对于每条可能的路由,累加该路由中所